openSUSE2021:0462-1: important: Security update for grub2

openSUSE Security Update: Security update for grub2 ______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0462-1 Rating: important References: #1175970 #1176711 #1177883 #1179264 #1179265 #1182057 #1182262 #1182263 #1183073 Cross-References: CVE-2020-14372 CVE-2020-25632 CVE-2020-25647 CVE-2020-27749 CVE-2020-27779 CVE-2021-20225 CVE-2021-20233 CVSS scores: CVE-2020-14372 (NVD) : 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2020-14372 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2020-25632 (NVD) : 8.2 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2020-25632 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2020-25647 (NVD) : 7.6 CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H CVE-2020-25647 (SUSE): 7.6 CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H CVE-2020-27749 (NVD) : 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVE-2020-27749 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2020-27779 (NVD) : 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2020-27779 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2021-20225 (NVD) : 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVE-2021-20225 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2021-20233 (NVD) : 8.2 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H CVE-2021-20233 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________
An update that solves 7 vulnerabilities and has two fixes is now available.
Description:
This update for grub2 fixes the following issues:
grub2 implements the new “SBAT” method for SHIM based secure boot revocation. (bsc#1182057)
– CVE-2020-25632: Fixed a use-after-free in rmmod command (bsc#1176711) – CVE-2020-25647: Fixed an out-of-bound write in grub_usb_device_initialize() (bsc#1177883) – CVE-2020-27749: Fixed a stack buffer overflow in grub_parser_split_cmdline (bsc#1179264) – CVE-2020-27779, CVE-2020-14372: Disallow cutmem and acpi commands in secure boot mode (bsc#1179265 bsc#1175970) – CVE-2021-20225: Fixed a heap out-of-bounds write in short form option parser (bsc#1182262) – CVE-2021-20233: Fixed a heap out-of-bound write due to mis-calculation of space required for quoting (bsc#1182263)
– Fixed chainloading windows on dual boot machine (bsc#1183073)
This update was imported from the SUSE:SLE-15-SP2:Update update project.
Patch Instructions:
To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”.
Alternatively you can run the command listed for your product:
– openSUSE Leap 15.2:
zypper in -t patch openSUSE-2021-462=1

Package List:
– openSUSE Leap 15.2 (i586 x86_64):
grub2-2.04-lp152.7.22.7 grub2-branding-upstream-2.04-lp152.7.22.7 grub2-debuginfo-2.04-lp152.7.22.7 grub2-debugsource-2.04-lp152.7.22.7
– openSUSE Leap 15.2 (noarch):
grub2-i386-efi-2.04-lp152.7.22.7 grub2-i386-efi-debug-2.04-lp152.7.22.7 grub2-i386-pc-2.04-lp152.7.22.7 grub2-i386-pc-debug-2.04-lp152.7.22.7 grub2-i386-xen-2.04-lp152.7.22.7 grub2-snapper-plugin-2.04-lp152.7.22.7 grub2-systemd-sleep-plugin-2.04-lp152.7.22.7 grub2-x86_64-efi-2.04-lp152.7.22.7 grub2-x86_64-efi-debug-2.04-lp152.7.22.7 grub2-x86_64-xen-2.04-lp152.7.22.7
References:
www.suse.com/security/cve/CVE-2020-14372.html www.suse.com/security/cve/CVE-2020-25632.html www.suse.com/security/cve/CVE-2020-25647.html www.suse.com/security/cve/CVE-2020-27749.html www.suse.com/security/cve/CVE-2020-27779.html www.suse.com/security/cve/CVE-2021-20225.html www.suse.com/security/cve/CVE-2021-20233.html bugzilla.suse.com/1175970 bugzilla.suse.com/1176711 bugzilla.suse.com/1177883 bugzilla.suse.com/1179264 bugzilla.suse.com/1179265 bugzilla.suse.com/1182057 bugzilla.suse.com/1182262 bugzilla.suse.com/1182263 bugzilla.suse.com/1183073