openSUSE2021:0469-1: important: Security update for ldb

openSUSE Security Update: Security update for ldb ______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0469-1 Rating: important References: #1183572 #1183574 Cross-References: CVE-2020-27840 CVE-2021-20277 CVSS scores: CVE-2020-27840 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2021-20277 (SUSE): 7.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________
An update that fixes two vulnerabilities is now available.
Description:
This update for ldb fixes the following issues:
– CVE-2020-27840: Fixed an unauthenticated remote heap corruption via bad DNs (bsc#1183572). – CVE-2021-20277: Fixed an out of bounds read in ldb_handler_fold (bsc#1183574).
This update was imported from the SUSE:SLE-15-SP2:Update update project.
Patch Instructions:
To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”.
Alternatively you can run the command listed for your product:
– openSUSE Leap 15.2:
zypper in -t patch openSUSE-2021-469=1

Package List:
– openSUSE Leap 15.2 (i586 x86_64):
ldb-debugsource-2.0.12-lp152.2.9.1 ldb-tools-2.0.12-lp152.2.9.1 ldb-tools-debuginfo-2.0.12-lp152.2.9.1 libldb-devel-2.0.12-lp152.2.9.1 libldb2-2.0.12-lp152.2.9.1 libldb2-debuginfo-2.0.12-lp152.2.9.1 python3-ldb-2.0.12-lp152.2.9.1 python3-ldb-debuginfo-2.0.12-lp152.2.9.1 python3-ldb-devel-2.0.12-lp152.2.9.1
– openSUSE Leap 15.2 (x86_64):
libldb2-32bit-2.0.12-lp152.2.9.1 libldb2-32bit-debuginfo-2.0.12-lp152.2.9.1 python3-ldb-32bit-2.0.12-lp152.2.9.1 python3-ldb-32bit-debuginfo-2.0.12-lp152.2.9.1
References:
www.suse.com/security/cve/CVE-2020-27840.html www.suse.com/security/cve/CVE-2021-20277.html bugzilla.suse.com/1183572 bugzilla.suse.com/1183574