[USN-4888-1] ldb vulnerabilities

========================================================================== Ubuntu Security Notice USN-4888-1 March 24, 2021
ldb vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 20.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS – Ubuntu 16.04 LTS
Summary:
Several security issues were fixed in ldb.
Software Description: – ldb: None
Details:
Douglas Bagnall discovered that ldb, when used with Samba, incorrectly handled certain LDAP attributes. A remote attacker could possibly use this issue to cause the LDAP server to crash, resulting in a denial of service. (CVE-2021-20277)
Douglas Bagnall discovered that ldb, when used with Samba, incorrectly handled certain DN strings. A remote attacker could use this issue to cause the LDAP server to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-27840)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 20.10: libldb2 2:2.1.4-2ubuntu0.1
Ubuntu 20.04 LTS: libldb2 2:2.0.10-0ubuntu0.20.04.3
Ubuntu 18.04 LTS: libldb1 2:1.2.3-1ubuntu0.2
Ubuntu 16.04 LTS: libldb1 2:1.1.24-1ubuntu3.2
After a standard system update you need to restart applications using ldb, such as Samba, to make all the necessary changes.
References: ubuntu.com/security/notices/USN-4888-1 CVE-2020-27840, CVE-2021-20277
Package Information: launchpad.net/ubuntu/+source/ldb/2:2.1.4-2ubuntu0.1 launchpad.net/ubuntu/+source/ldb/2:2.0.10-0ubuntu0.20.04.3 launchpad.net/ubuntu/+source/ldb/2:1.2.3-1ubuntu0.2 launchpad.net/ubuntu/+source/ldb/2:1.1.24-1ubuntu3.2