[USN-4891-1] OpenSSL vulnerability

========================================================================== Ubuntu Security Notice USN-4891-1 March 25, 2021
openssl vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 20.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
OpenSSL could be made to crash or run programs if it received specially crafted network traffic.
Software Description: – openssl: Secure Socket Layer (SSL) cryptographic library and tools
Details:
It was discovered that OpenSSL incorrectly handled certain renegotiation ClientHello messages. A remote attacker could use this issue to cause OpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 20.10: libssl1.1 1.1.1f-1ubuntu4.3
Ubuntu 20.04 LTS: libssl1.1 1.1.1f-1ubuntu2.3
Ubuntu 18.04 LTS: libssl1.1 1.1.1-1ubuntu2.1~18.04.9
After a standard system update you need to reboot your computer to make all the necessary changes.
References: ubuntu.com/security/notices/USN-4891-1 CVE-2021-3449
Package Information: launchpad.net/ubuntu/+source/openssl/1.1.1f-1ubuntu4.3 launchpad.net/ubuntu/+source/openssl/1.1.1f-1ubuntu2.3 launchpad.net/ubuntu/+source/openssl/1.1.1-1ubuntu2.1~18.04.9