openSUSE2021:0510-1: moderate: Security update for curl

openSUSE Security Update: Security update for curl ______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0510-1 Rating: moderate References: #1183933 #1183934 Cross-References: CVE-2021-22876 CVE-2021-22890 CVSS scores: CVE-2021-22876 (SUSE): 6.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N CVE-2021-22890 (SUSE): 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________
An update that fixes two vulnerabilities is now available.
Description:
This update for curl fixes the following issues:
– CVE-2021-22890: TLS 1.3 session ticket proxy host mixup (bsc#1183934) – CVE-2021-22876: Automatic referer leaks credentials (bsc#1183933)
This update was imported from the SUSE:SLE-15-SP2:Update update project.
Patch Instructions:
To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”.
Alternatively you can run the command listed for your product:
– openSUSE Leap 15.2:
zypper in -t patch openSUSE-2021-510=1

Package List:
– openSUSE Leap 15.2 (i586 x86_64):
curl-7.66.0-lp152.3.15.1 curl-debuginfo-7.66.0-lp152.3.15.1 curl-debugsource-7.66.0-lp152.3.15.1 curl-mini-7.66.0-lp152.3.15.1 curl-mini-debuginfo-7.66.0-lp152.3.15.1 curl-mini-debugsource-7.66.0-lp152.3.15.1 libcurl-devel-7.66.0-lp152.3.15.1 libcurl-mini-devel-7.66.0-lp152.3.15.1 libcurl4-7.66.0-lp152.3.15.1 libcurl4-debuginfo-7.66.0-lp152.3.15.1 libcurl4-mini-7.66.0-lp152.3.15.1 libcurl4-mini-debuginfo-7.66.0-lp152.3.15.1
– openSUSE Leap 15.2 (x86_64):
libcurl-devel-32bit-7.66.0-lp152.3.15.1 libcurl4-32bit-7.66.0-lp152.3.15.1 libcurl4-32bit-debuginfo-7.66.0-lp152.3.15.1
References:
www.suse.com/security/cve/CVE-2021-22876.html www.suse.com/security/cve/CVE-2021-22890.html bugzilla.suse.com/1183933 bugzilla.suse.com/1183934