openSUSE2021:0607-1: moderate: Security update for ruby2.5

openSUSE Security Update: Security update for ruby2.5 ______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0607-1 Rating: moderate References: #1184644 Cross-References: CVE-2021-28965 CVSS scores: CVE-2021-28965 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________
An update that fixes one vulnerability is now available.
Description:
This update for ruby2.5 fixes the following issues:
– Update to 2.5.9 – CVE-2021-28965: XML round-trip vulnerability in REXML (bsc#1184644)
This update was imported from the SUSE:SLE-15:Update update project.
Patch Instructions:
To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”.
Alternatively you can run the command listed for your product:
– openSUSE Leap 15.2:
zypper in -t patch openSUSE-2021-607=1

Package List:
– openSUSE Leap 15.2 (x86_64):
libruby2_5-2_5-2.5.9-lp152.2.6.1 libruby2_5-2_5-debuginfo-2.5.9-lp152.2.6.1 ruby2.5-2.5.9-lp152.2.6.1 ruby2.5-debuginfo-2.5.9-lp152.2.6.1 ruby2.5-debugsource-2.5.9-lp152.2.6.1 ruby2.5-devel-2.5.9-lp152.2.6.1 ruby2.5-devel-extra-2.5.9-lp152.2.6.1 ruby2.5-doc-2.5.9-lp152.2.6.1 ruby2.5-stdlib-2.5.9-lp152.2.6.1 ruby2.5-stdlib-debuginfo-2.5.9-lp152.2.6.1
– openSUSE Leap 15.2 (noarch):
ruby2.5-doc-ri-2.5.9-lp152.2.6.1
References:
www.suse.com/security/cve/CVE-2021-28965.html bugzilla.suse.com/1184644