[gentoo-announce] [ GLSA 202105-28 ] MariaDB: Multiple vulnerabilities

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – Gentoo Linux Security Advisory GLSA 202105-28 – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – security.gentoo.org/ – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Severity: Normal Title: MariaDB: Multiple vulnerabilities Date: May 26, 2021 Bugs: #777786, #789240 ID: 202105-28
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Synopsis ========
Multiple vulnerabilities have been found in MariaDB, the worst of which could result in the arbitrary execution of code.
Background ==========
MariaDB is an enhanced, drop-in replacement for MySQL.
Affected packages =================
——————————————————————- Package / Vulnerable / Unaffected ——————————————————————- 1 dev-db/mariadb < 10.5.10 >= 10.2.38:10.2 >= 10.3.29:10.3 >= 10.4.19:10.4 >= 10.5.10:10.5
Description ===========
Multiple vulnerabilities have been discovered in MariaDB. Please review the CVE identifiers referenced below for details.
Impact ======
Please review the referenced CVE identifiers for details.
Workaround ==========
There is no known workaround at this time.
Resolution ==========
All MariaDB 10.2.x users should upgrade to the latest version:
# emerge –sync # emerge –ask –oneshot –verbose “>=dev-db/mariadb-10.2.38:10.2”
All MariaDB 10.3.x users should upgrade to the latest version:
# emerge –sync # emerge –ask –oneshot –verbose “>=dev-db/mariadb-10.3.29:10.3”
All MariaDB 10.3.x users should upgrade to the latest version:
# emerge –sync # emerge –ask –oneshot –verbose “>=dev-db/mariadb-10.4.19:10.4”
All MariaDB 10.5.x users should upgrade to the latest version:
# emerge –sync # emerge –ask –oneshot –verbose “>=dev-db/mariadb-10.5.10:10.5”
References ==========
[ 1 ] CVE-2021-2154 nvd.nist.gov/vuln/detail/CVE-2021-2154 [ 2 ] CVE-2021-2166 nvd.nist.gov/vuln/detail/CVE-2021-2166 [ 3 ] CVE-2021-2180 nvd.nist.gov/vuln/detail/CVE-2021-2180 [ 4 ] CVE-2021-27928 nvd.nist.gov/vuln/detail/CVE-2021-27928
Availability ============
This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
security.gentoo.org/glsa/202105-28
Concerns? =========
Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users’ machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at bugs.gentoo.org.
License =======
Copyright 2021 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons – Attribution / Share Alike license.
creativecommons.org/licenses/by-sa/2.5