[USN-4933-1] OpenVPN vulnerabilities

========================================================================== Ubuntu Security Notice USN-4933-1 May 04, 2021
openvpn vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.04 – Ubuntu 20.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
everal security issues were fixed in OpenVPN.
Software Description: – openvpn: virtual private network software
Details:
It was discovered that OpenVPN incorrectly handled certain data channel v2 packets. A remote attacker could possibly use this issue to inject packets using a victim’s peer-id. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-11810)
It was discovered that OpenVPN incorrectly handled deferred authentication. When a server is configured to use deferred authentication, a remote attacker could possibly use this issue to bypass authentication and access control channel data. (CVE-2020-15078)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.04: openvpn 2.5.1-1ubuntu1.1
Ubuntu 20.10: openvpn 2.4.9-3ubuntu1.1
Ubuntu 20.04 LTS: openvpn 2.4.7-1ubuntu2.20.04.2
Ubuntu 18.04 LTS: openvpn 2.4.4-2ubuntu1.5
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-4933-1 CVE-2020-11810, CVE-2020-15078
Package Information: launchpad.net/ubuntu/+source/openvpn/2.5.1-1ubuntu1.1 launchpad.net/ubuntu/+source/openvpn/2.4.9-3ubuntu1.1 launchpad.net/ubuntu/+source/openvpn/2.4.7-1ubuntu2.20.04.2 launchpad.net/ubuntu/+source/openvpn/2.4.4-2ubuntu1.5