openSUSE2021:0919-1: important: Security update for libgcrypt

openSUSE Security Update: Security update for libgcrypt ______________________________________________________________________________
Announcement ID: openSUSE-SU-2021:0919-1 Rating: important References: #1187212 Cross-References: CVE-2021-33560 CVSS scores: CVE-2021-33560 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVE-2021-33560 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Affected Products: openSUSE Leap 15.2 ______________________________________________________________________________
An update that fixes one vulnerability is now available.
Description:
This update for libgcrypt fixes the following issues:
– CVE-2021-33560: Fixed a side-channel against ElGamal encryption, caused by missing exponent blinding (bsc#1187212).
This update was imported from the SUSE:SLE-15-SP1:Update update project.
Patch Instructions:
To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”.
Alternatively you can run the command listed for your product:
– openSUSE Leap 15.2:
zypper in -t patch openSUSE-2021-919=1

Package List:
– openSUSE Leap 15.2 (i586 x86_64):
libgcrypt-cavs-1.8.2-lp152.17.3.1 libgcrypt-cavs-debuginfo-1.8.2-lp152.17.3.1 libgcrypt-debugsource-1.8.2-lp152.17.3.1 libgcrypt-devel-1.8.2-lp152.17.3.1 libgcrypt-devel-debuginfo-1.8.2-lp152.17.3.1 libgcrypt20-1.8.2-lp152.17.3.1 libgcrypt20-debuginfo-1.8.2-lp152.17.3.1 libgcrypt20-hmac-1.8.2-lp152.17.3.1
– openSUSE Leap 15.2 (x86_64):
libgcrypt-devel-32bit-1.8.2-lp152.17.3.1 libgcrypt-devel-32bit-debuginfo-1.8.2-lp152.17.3.1 libgcrypt20-32bit-1.8.2-lp152.17.3.1 libgcrypt20-32bit-debuginfo-1.8.2-lp152.17.3.1 libgcrypt20-hmac-32bit-1.8.2-lp152.17.3.1
References:
www.suse.com/security/cve/CVE-2021-33560.html bugzilla.suse.com/1187212