[USN-4976-1] Dnsmasq vulnerability

========================================================================== Ubuntu Security Notice USN-4976-1 June 02, 2021
dnsmasq vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.04 – Ubuntu 20.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Dnsmasq could be exposed to cache poisoning.
Software Description: – dnsmasq: Small caching DNS proxy and DHCP/TFTP server
Details:
Petr Mensik discovered that Dnsmasq incorrectly randomized source ports in certain configurations. A remote attacker could possibly use this issue to facilitate DNS cache poisoning attacks.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.04: dnsmasq 2.84-1ubuntu2.1 dnsmasq-base 2.84-1ubuntu2.1 dnsmasq-utils 2.84-1ubuntu2.1
Ubuntu 20.10: dnsmasq 2.82-1ubuntu1.3 dnsmasq-base 2.82-1ubuntu1.3 dnsmasq-utils 2.82-1ubuntu1.3
Ubuntu 20.04 LTS: dnsmasq 2.80-1.1ubuntu1.4 dnsmasq-base 2.80-1.1ubuntu1.4 dnsmasq-utils 2.80-1.1ubuntu1.4
Ubuntu 18.04 LTS: dnsmasq 2.79-1ubuntu0.4 dnsmasq-base 2.79-1ubuntu0.4 dnsmasq-utils 2.79-1ubuntu0.4
After a standard system update you need to reboot your computer to make all the necessary changes.
References: ubuntu.com/security/notices/USN-4976-1 CVE-2021-3448
Package Information: launchpad.net/ubuntu/+source/dnsmasq/2.84-1ubuntu2.1 launchpad.net/ubuntu/+source/dnsmasq/2.82-1ubuntu1.3 launchpad.net/ubuntu/+source/dnsmasq/2.80-1.1ubuntu1.4 launchpad.net/ubuntu/+source/dnsmasq/2.79-1ubuntu0.4