[USN-5066-1] PySAML2 vulnerability

========================================================================== Ubuntu Security Notice USN-5066-1 September 08, 2021
python-pysaml2 vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.04 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
PySAML2 could be made to accept invalid SAML documents.
Software Description: – python-pysaml2: Pure python implementation of SAML2
Details:
Brian Wolff discovered that PySAML2 incorrectly validated cryptographic signatures. A remote attacker could possibly use this issue to alter SAML documents.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.04: python3-pysaml2 6.1.0-0ubuntu1.21.04.1
Ubuntu 20.04 LTS: python3-pysaml2 4.9.0-0ubuntu3.1
Ubuntu 18.04 LTS: python-pysaml2 4.0.2-0ubuntu3.2 python3-pysaml2 4.0.2-0ubuntu3.2
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5066-1 CVE-2021-21239
Package Information: launchpad.net/ubuntu/+source/python-pysaml2/6.1.0-0ubuntu1.21.04.1 launchpad.net/ubuntu/+source/python-pysaml2/4.9.0-0ubuntu3.1 launchpad.net/ubuntu/+source/python-pysaml2/4.0.2-0ubuntu3.2