[USN-5076-1] Git vulnerability

========================================================================== Ubuntu Security Notice USN-5076-1 September 13, 2021
git vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 20.04 LTS – Ubuntu 18.04 LTS – Ubuntu 16.04 ESM
Summary:
Git incorrectly handled certain repository paths.
Software Description: – git: fast, scalable, distributed revision control system
Details:
It was discovered that Git allowed newline characters in certain repository paths. An attacker could potentially use this issue to perform cross-protocol requests.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 20.04 LTS: git 1:2.25.1-1ubuntu3.2
Ubuntu 18.04 LTS: git 1:2.17.1-1ubuntu0.9
Ubuntu 16.04 ESM: git 1:2.7.4-0ubuntu1.10+esm1
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5076-1 CVE-2021-40330
Package Information: launchpad.net/ubuntu/+source/git/1:2.25.1-1ubuntu3.2 launchpad.net/ubuntu/+source/git/1:2.17.1-1ubuntu0.9