[USN-5168-4] NSS regression

========================================================================== Ubuntu Security Notice USN-5168-4 December 07, 2021
nss regression ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 16.04 ESM – Ubuntu 14.04 ESM
Summary:
USN-5168-3 introduced a regression in NSS.
Software Description: – nss: Network Security Service library
Details:
USN-5168-3 fixed a vulnerability in NSS. Unfortunately that update introduced a regression that could break SSL connections. This update fixes the problem.
We apologize for the inconvenience.
Original advisory details:
Tavis Ormandy discovered that NSS incorrectly handled verifying DSA/RSA-PSS signatures. A remote attacker could use this issue to cause NSS to crash, resulting in a denial of service, or possibly execute arbitrary code.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 16.04 ESM: libnss3 2:3.28.4-0ubuntu0.16.04.14+esm2
Ubuntu 14.04 ESM: libnss3 2:3.28.4-0ubuntu0.14.04.5+esm10
After a standard system update you need to restart any applications that use NSS, such as Evolution, to make all the necessary changes.
References: ubuntu.com/security/notices/USN-5168-4 ubuntu.com/security/notices/USN-5168-1 CVE-2021-43527