[USN-5173-1] libmodbus vulnerabilities

========================================================================== Ubuntu Security Notice USN-5173-1 December 06, 2021
libmodbus vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 18.04 LTS
Summary:
libmodbus could be made to crash if it received specially crafted input.
Software Description: – libmodbus: Library to send/receive data according to the Modbus protocol
Details:
It was discovered that libmodbus incorrectly handled inputs. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 18.04 LTS: libmodbus5 3.0.6-2+deb9u1build0.18.04.1
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5173-1 CVE-2019-14462, CVE-2019-14463
Package Information: launchpad.net/ubuntu/+source/libmodbus/3.0.6-2+deb9u1build0.18.04.1