[USN-5212-1] Apache HTTP Server vulnerabilities

========================================================================== Ubuntu Security Notice USN-5212-1 January 06, 2022
apache2 vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 21.04 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Several security issues were fixed in Apache HTTP Server.
Software Description: – apache2: Apache HTTP server
Details:
It was discovered that the Apache HTTP Server incorrectly handled certain forward proxy requests. A remote attacker could use this issue to cause the server to crash, resulting in a denial of service, or possibly perform a Server Side Request Forgery attack. (CVE-2021-44224)
It was discovered that the Apache HTTP Server Lua module incorrectly handled memory in the multipart parser. A remote attacker could use this issue to cause the server to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2021-44790)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: apache2 2.4.48-3.1ubuntu3.2 apache2-bin 2.4.48-3.1ubuntu3.2
Ubuntu 21.04: apache2 2.4.46-4ubuntu1.5 apache2-bin 2.4.46-4ubuntu1.5
Ubuntu 20.04 LTS: apache2 2.4.41-4ubuntu3.9 apache2-bin 2.4.41-4ubuntu3.9
Ubuntu 18.04 LTS: apache2 2.4.29-1ubuntu4.21 apache2-bin 2.4.29-1ubuntu4.21
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5212-1 CVE-2021-44224, CVE-2021-44790
Package Information: launchpad.net/ubuntu/+source/apache2/2.4.48-3.1ubuntu3.2 launchpad.net/ubuntu/+source/apache2/2.4.46-4ubuntu1.5 launchpad.net/ubuntu/+source/apache2/2.4.41-4ubuntu3.9 launchpad.net/ubuntu/+source/apache2/2.4.29-1ubuntu4.21