[USN-5241-1] QtSvg vulnerabilities

========================================================================== Ubuntu Security Notice USN-5241-1 January 19, 2022
qtsvg-opensource-src vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 18.04 LTS
Summary:
Several security issues were fixed in QtSvg.
Software Description: – qtsvg-opensource-src: Qt 5 SVG module
Details:
It was discovered that QtSvg incorrectly handled certain malformed SVG images. If a user or automated system were tricked into opening a specially crafted image file, a remote attacker could use this issue to cause QtSvg to crash, resulting in a denial of service, or possibly execute arbitrary code.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 18.04 LTS: libqt5svg5 5.9.5-0ubuntu1.1
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5241-1 CVE-2018-19869, CVE-2021-3481, CVE-2021-45930
Package Information: launchpad.net/ubuntu/+source/qtsvg-opensource-src/5.9.5-0ubuntu1.1