[USN-5250-1] strongSwan vulnerability

========================================================================== Ubuntu Security Notice USN-5250-1 January 24, 2022
strongswan vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
strongSwan could crash or allow unintended access to network services.
Software Description: – strongswan: IPsec VPN solution
Details:
Zhuowei Zhang discovered that stringSwan incorrectly handled EAP authentication. A remote attacker could use this issue to cause strongSwan to crash, resulting in a denial of service, or possibly bypass client and server authentication.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: libstrongswan 5.9.1-1ubuntu3.2 strongswan 5.9.1-1ubuntu3.2
Ubuntu 20.04 LTS: libstrongswan 5.8.2-1ubuntu3.4 strongswan 5.8.2-1ubuntu3.4
Ubuntu 18.04 LTS: libstrongswan 5.6.2-1ubuntu2.8 strongswan 5.6.2-1ubuntu2.8
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5250-1 CVE-2021-45079
Package Information: launchpad.net/ubuntu/+source/strongswan/5.9.1-1ubuntu3.2 launchpad.net/ubuntu/+source/strongswan/5.8.2-1ubuntu3.4 launchpad.net/ubuntu/+source/strongswan/5.6.2-1ubuntu2.8