[USN-5267-1] Linux kernel vulnerabilities

========================================================================== Ubuntu Security Notice USN-5267-1 February 03, 2022
linux, linux-aws, linux-aws-5.4, linux-bluefield, linux-gcp, linux-gcp-5.4, linux-gkeop, linux-gkeop-5.4, linux-hwe-5.4, linux-ibm, linux-kvm, linux-oracle, linux-oracle-5.4 vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Several security issues were fixed in the Linux kernel.
Software Description: – linux: Linux kernel – linux-aws: Linux kernel for Amazon Web Services (AWS) systems – linux-bluefield: Linux kernel for NVIDIA BlueField platforms – linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems – linux-gkeop: Linux kernel for Google Container Engine (GKE) systems – linux-ibm: Linux kernel for IBM cloud systems – linux-kvm: Linux kernel for cloud environments – linux-oracle: Linux kernel for Oracle Cloud systems – linux-aws-5.4: Linux kernel for Amazon Web Services (AWS) systems – linux-gcp-5.4: Linux kernel for Google Cloud Platform (GCP) systems – linux-gkeop-5.4: Linux kernel for Google Container Engine (GKE) systems – linux-hwe-5.4: Linux hardware enablement (HWE) kernel – linux-oracle-5.4: Linux kernel for Oracle Cloud systems
Details:
It was discovered that the Bluetooth subsystem in the Linux kernel contained a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-3640)
Likang Luo discovered that a race condition existed in the Bluetooth subsystem of the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-3752)
Luo Likang discovered that the FireDTV Firewire driver in the Linux kernel did not properly perform bounds checking in some situations. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-42739)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 20.04 LTS: linux-image-5.4.0-1013-ibm 5.4.0-1013.14 linux-image-5.4.0-1026-bluefield 5.4.0-1026.29 linux-image-5.4.0-1032-gkeop 5.4.0-1032.33 linux-image-5.4.0-1054-kvm 5.4.0-1054.56 linux-image-5.4.0-1062-oracle 5.4.0-1062.66 linux-image-5.4.0-1063-gcp 5.4.0-1063.67 linux-image-5.4.0-1064-aws 5.4.0-1064.67 linux-image-5.4.0-97-generic 5.4.0-97.110 linux-image-5.4.0-97-generic-lpae 5.4.0-97.110 linux-image-5.4.0-97-lowlatency 5.4.0-97.110 linux-image-aws-lts-20.04 5.4.0.1064.66 linux-image-bluefield 5.4.0.1026.27 linux-image-gcp-lts-20.04 5.4.0.1063.73 linux-image-generic 5.4.0.97.101 linux-image-generic-hwe-18.04 5.4.0.97.101 linux-image-generic-hwe-18.04-edge 5.4.0.97.101 linux-image-generic-lpae 5.4.0.97.101 linux-image-generic-lpae-hwe-18.04 5.4.0.97.101 linux-image-generic-lpae-hwe-18.04-edge 5.4.0.97.101 linux-image-gkeop 5.4.0.1032.35 linux-image-gkeop-5.4 5.4.0.1032.35 linux-image-ibm 5.4.0.1013.14 linux-image-ibm-lts-20.04 5.4.0.1013.14 linux-image-kvm 5.4.0.1054.53 linux-image-lowlatency 5.4.0.97.101 linux-image-lowlatency-hwe-18.04 5.4.0.97.101 linux-image-lowlatency-hwe-18.04-edge 5.4.0.97.101 linux-image-oem 5.4.0.97.101 linux-image-oem-osp1 5.4.0.97.101 linux-image-oracle-lts-20.04 5.4.0.1062.62 linux-image-virtual 5.4.0.97.101 linux-image-virtual-hwe-18.04 5.4.0.97.101 linux-image-virtual-hwe-18.04-edge 5.4.0.97.101
Ubuntu 18.04 LTS: linux-image-5.4.0-1032-gkeop 5.4.0-1032.33~18.04.1 linux-image-5.4.0-1062-oracle 5.4.0-1062.66~18.04.1 linux-image-5.4.0-1063-gcp 5.4.0-1063.67~18.04.1 linux-image-5.4.0-97-generic 5.4.0-97.110~18.04.1 linux-image-5.4.0-97-generic-lpae 5.4.0-97.110~18.04.1 linux-image-5.4.0-97-lowlatency 5.4.0-97.110~18.04.1 linux-image-aws 5.4.0.1064.46 linux-image-gcp 5.4.0.1063.48 linux-image-generic-hwe-18.04 5.4.0.97.110~18.04.85 linux-image-generic-lpae-hwe-18.04 5.4.0.97.110~18.04.85 linux-image-gkeop-5.4 5.4.0.1032.33~18.04.32 linux-image-lowlatency-hwe-18.04 5.4.0.97.110~18.04.85 linux-image-oem 5.4.0.97.110~18.04.85 linux-image-oem-osp1 5.4.0.97.110~18.04.85 linux-image-oracle 5.4.0.1062.66~18.04.41 linux-image-snapdragon-hwe-18.04 5.4.0.97.110~18.04.85 linux-image-virtual-hwe-18.04 5.4.0.97.110~18.04.85
After a standard system update you need to reboot your computer to make all the necessary changes.
ATTENTION: Due to an unavoidable ABI change the kernel updates have been given a new version number, which requires you to recompile and reinstall all third party kernel modules you might have installed. Unless you manually uninstalled the standard kernel metapackages (e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual, linux-powerpc), a standard system upgrade will automatically perform this as well.
References: ubuntu.com/security/notices/USN-5267-1 CVE-2021-3640, CVE-2021-3752, CVE-2021-42739
Package Information: launchpad.net/ubuntu/+source/linux/5.4.0-97.110 launchpad.net/ubuntu/+source/linux-aws/5.4.0-1064.67 launchpad.net/ubuntu/+source/linux-bluefield/5.4.0-1026.29 launchpad.net/ubuntu/+source/linux-gcp/5.4.0-1063.67 launchpad.net/ubuntu/+source/linux-gkeop/5.4.0-1032.33 launchpad.net/ubuntu/+source/linux-ibm/5.4.0-1013.14 launchpad.net/ubuntu/+source/linux-kvm/5.4.0-1054.56 launchpad.net/ubuntu/+source/linux-oracle/5.4.0-1062.66 launchpad.net/ubuntu/+source/linux-aws-5.4/5.4.0-1064.67~18.04.1 launchpad.net/ubuntu/+source/linux-gcp-5.4/5.4.0-1063.67~18.04.1 launchpad.net/ubuntu/+source/linux-gkeop-5.4/5.4.0-1032.33~18.04.1 launchpad.net/ubuntu/+source/linux-hwe-5.4/5.4.0-97.110~18.04.1 launchpad.net/ubuntu/+source/linux-oracle-5.4/5.4.0-1062.66~18.04.1