[USN-5276-1] NVIDIA graphics drivers vulnerabilities

========================================================================== Ubuntu Security Notice USN-5276-1 February 08, 2022
nvidia-graphics-drivers-450-server, nvidia-graphics-drivers-470, nvidia-graphics-drivers-470-server, nvidia-graphics-drivers-510 vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Several security issues were fixed in NVIDIA graphics drivers.
Software Description: – nvidia-graphics-drivers-450-server: NVIDIA Server Driver – nvidia-graphics-drivers-470: NVIDIA binary X.Org driver – nvidia-graphics-drivers-470-server: NVIDIA Server Driver – nvidia-graphics-drivers-510: NVIDIA binary X.Org driver
Details:
It was discovered that the NVIDIA graphics drivers incorrectly handled permissions in the kernel mode layer. A local attacker could use this issue to write to protected memory and cause a denial of service.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: xserver-xorg-video-nvidia-440-server 450.172.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-450-server 450.172.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-460 470.103.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-460-server 470.103.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-465 470.103.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-470 470.103.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-470-server 470.103.01-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-495 510.47.03-0ubuntu0.21.10.1 xserver-xorg-video-nvidia-510 510.47.03-0ubuntu0.21.10.1
Ubuntu 20.04 LTS: xserver-xorg-video-nvidia-440-server 450.172.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-450-server 450.172.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-460 470.103.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-460-server 470.103.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-465 470.103.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-470 470.103.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-470-server 470.103.01-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-495 510.47.03-0ubuntu0.20.04.1 xserver-xorg-video-nvidia-510 510.47.03-0ubuntu0.20.04.1
Ubuntu 18.04 LTS: xserver-xorg-video-nvidia-440-server 450.172.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-450-server 450.172.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-460 470.103.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-460-server 470.103.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-465 470.103.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-470 470.103.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-470-server 470.103.01-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-495 510.47.03-0ubuntu0.18.04.1 xserver-xorg-video-nvidia-510 510.47.03-0ubuntu0.18.04.1
After a standard system update you need to reboot your computer to make all the necessary changes.
References: ubuntu.com/security/notices/USN-5276-1 CVE-2022-21813, CVE-2022-21814
Package Information:
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-450-server/450.172.01-0ubuntu0.21.10.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-470/470.103.01-0ubuntu0.21.10.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-470-server/470.103.01-0ubuntu0.21.10.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-510/510.47.03-0ubuntu0.21.10.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-450-server/450.172.01-0ubuntu0.20.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-470/470.103.01-0ubuntu0.20.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-470-server/470.103.01-0ubuntu0.20.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-510/510.47.03-0ubuntu0.20.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-450-server/450.172.01-0ubuntu0.18.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-470/470.103.01-0ubuntu0.18.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-470-server/470.103.01-0ubuntu0.18.04.1
launchpad.net/ubuntu/+source/nvidia-graphics-drivers-510/510.47.03-0ubuntu0.18.04.1