[USN-5286-1] cryptsetup vulnerability

========================================================================== Ubuntu Security Notice USN-5286-1 February 15, 2022
cryptsetup vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS
Summary:
cryptsetup could be made to expose sensitive information.
Software Description: – cryptsetup: disk encryption support
Details:
Milan Broz discovered that cryptsetup incorrectly handled LUKS2 reencryption recovery. An attacker with physical access to modify the encrypted device header may trigger the device to be unencrypted the next time it is mounted by the user.
On Ubuntu 20.04 LTS, this issue was fixed by disabling the online reencryption feature.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: cryptsetup 2:2.3.7-0ubuntu0.21.10.1
Ubuntu 20.04 LTS: cryptsetup 2:2.2.2-3ubuntu2.4
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5286-1 CVE-2021-4122
Package Information: launchpad.net/ubuntu/+source/cryptsetup/2:2.3.7-0ubuntu0.21.10.1 launchpad.net/ubuntu/+source/cryptsetup/2:2.2.2-3ubuntu2.4