[USN-5301-1] Cyrus SASL vulnerability

========================================================================== Ubuntu Security Notice USN-5301-1 February 22, 2022
cyrus-sasl2 vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Cyrus SASL could run programs if it received specially crafted network traffic.
Software Description: – cyrus-sasl2: Cyrus Simple Authentication and Security Layer
Details:
It was discovered that the Cyrus SASL SQL plugin incorrectly handled SQL input. A remote attacker could use this issue to execute arbitrary SQL commands.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: libsasl2-modules-sql 2.1.27+dfsg-2.1ubuntu0.1
Ubuntu 20.04 LTS: libsasl2-modules-sql 2.1.27+dfsg-2ubuntu0.1
Ubuntu 18.04 LTS: libsasl2-modules-sql 2.1.27~101-g0780600+dfsg-3ubuntu2.4
After a standard system update you need to reboot your computer to make all the necessary changes.
References: ubuntu.com/security/notices/USN-5301-1 CVE-2022-24407
Package Information: launchpad.net/ubuntu/+source/cyrus-sasl2/2.1.27+dfsg-2.1ubuntu0.1 launchpad.net/ubuntu/+source/cyrus-sasl2/2.1.27+dfsg-2ubuntu0.1
launchpad.net/ubuntu/+source/cyrus-sasl2/2.1.27~101-g0780600+dfsg-3ubuntu2.4