[USN-5304-1] PolicyKit vulnerability

========================================================================== Ubuntu Security Notice USN-5304-1 February 28, 2022
policykit-1 vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS
Summary:
policykit-1 could be made to crash if it received specially crafted data.
Software Description: – policykit-1: framework for managing administrative policies and privileges
Details:
Kevin Backhouse discovered that PolicyKit incorrectly handled file descriptors. A local attacker could possibly use this issue to cause PolicyKit to crash, resulting in a denial of service.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: policykit-1 0.105-31ubuntu0.2
Ubuntu 20.04 LTS: policykit-1 0.105-26ubuntu1.3
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5304-1 CVE-2021-4115
Package Information: launchpad.net/ubuntu/+source/policykit-1/0.105-31ubuntu0.2 launchpad.net/ubuntu/+source/policykit-1/0.105-26ubuntu1.3