[USN-5355-1] zlib vulnerability


========================================================================== Ubuntu Security Notice USN-5355-1 March 30, 2022
zlib vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
zlib could be made to crash or run programs if it received specially crafted input.
Software Description: – zlib: Lossless data-compression library
Details:
Danilo Ramos discovered that zlib incorrectly handled memory when performing certain deflating operations. An attacker could use this issue to cause zlib to crash, resulting in a denial of service, or possibly execute arbitrary code.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: lib32z1 1:1.2.11.dfsg-2ubuntu7.1 lib64z1 1:1.2.11.dfsg-2ubuntu7.1 libx32z1 1:1.2.11.dfsg-2ubuntu7.1 zlib1g 1:1.2.11.dfsg-2ubuntu7.1
Ubuntu 20.04 LTS: lib32z1 1:1.2.11.dfsg-2ubuntu1.3 lib64z1 1:1.2.11.dfsg-2ubuntu1.3 libx32z1 1:1.2.11.dfsg-2ubuntu1.3 zlib1g 1:1.2.11.dfsg-2ubuntu1.3
Ubuntu 18.04 LTS: lib32z1 1:1.2.11.dfsg-0ubuntu2.1 lib64z1 1:1.2.11.dfsg-0ubuntu2.1 libx32z1 1:1.2.11.dfsg-0ubuntu2.1 zlib1g 1:1.2.11.dfsg-0ubuntu2.1
After a standard system update you need to reboot your computer to make all the necessary changes.
References: ubuntu.com/security/notices/USN-5355-1 CVE-2018-25032
Package Information: launchpad.net/ubuntu/+source/zlib/1:1.2.11.dfsg-2ubuntu7.1 launchpad.net/ubuntu/+source/zlib/1:1.2.11.dfsg-2ubuntu1.3 launchpad.net/ubuntu/+source/zlib/1:1.2.11.dfsg-0ubuntu2.1