[USN-5365-1] H2 vulnerabilities


========================================================================== Ubuntu Security Notice USN-5365-1 April 05, 2022
h2database vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS
Summary:
Several security issues were fixed in H2.
Software Description: – h2database: H2 Database Engine
Details:
It was discovered that H2 was vulnerable to deserialization of untrusted data. An attacker could possibly use this issue to execute arbitrary code. (CVE-2021-42392)
It was discovered that H2 incorrectly handled some specially crafted connection URLs. An attacker could possibly use this issue to execute arbitrary code. (CVE-2022-23221)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: libh2-java 1.4.197-4+deb10u1build0.21.10.1
Ubuntu 20.04 LTS: libh2-java 1.4.197-4+deb10u1build0.20.04.1
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5365-1 CVE-2021-42392, CVE-2022-23221
Package Information: launchpad.net/ubuntu/+source/h2database/1.4.197-4+deb10u1build0.21.10.1 launchpad.net/ubuntu/+source/h2database/1.4.197-4+deb10u1build0.20.04.1