[USN-5369-1] oslo.utils vulnerability


========================================================================== Ubuntu Security Notice USN-5369-1 April 07, 2022
python-oslo.utils vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS – Ubuntu 16.04 ESM
Summary:
oslo.utils could be made to expose sensitive information if it received a specially crafted input.
Software Description: – python-oslo.utils: Oslo Utility library – doc
Details:
It was discovered that oslo.utils incorrectly handled certain inputs. An attacker could possibly use this issue to expose sensitive information.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 21.10: python3-oslo.utils 4.10.0-0ubuntu1.1
Ubuntu 20.04 LTS: python3-oslo.utils 4.1.1-0ubuntu1.1
Ubuntu 18.04 LTS: python-oslo.utils 3.35.0-0ubuntu1.1 python3-oslo.utils 3.35.0-0ubuntu1.1
Ubuntu 16.04 ESM: python-oslo.utils 3.8.0-2ubuntu0.1~esm1 python3-oslo.utils 3.8.0-2ubuntu0.1~esm1
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5369-1 CVE-2022-0718
Package Information: launchpad.net/ubuntu/+source/python-oslo.utils/4.10.0-0ubuntu1.1 launchpad.net/ubuntu/+source/python-oslo.utils/4.1.1-0ubuntu1.1 launchpad.net/ubuntu/+source/python-oslo.utils/3.35.0-0ubuntu1.1