[USN-5395-1] networkd-dispatcher vulnerabilities


========================================================================== Ubuntu Security Notice USN-5395-1 April 28, 2022
networkd-dispatcher vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 22.04 LTS – Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Several security issues were fixed in networkd-dispatcher.
Software Description: – networkd-dispatcher: Dispatcher service for systemd-networkd connection status changes
Details:
It was discovered that networkd-dispatcher incorrectly handled internal scripts. A local attacker could possibly use this issue to cause a race condition, escalate privileges and execute arbitrary code. (CVE-2022-29799, CVE-2022-29800)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 22.04 LTS: networkd-dispatcher 2.1-2ubuntu0.22.04.1
Ubuntu 21.10: networkd-dispatcher 2.1-2ubuntu0.21.10.1
Ubuntu 20.04 LTS: networkd-dispatcher 2.1-2~ubuntu20.04.2
Ubuntu 18.04 LTS: networkd-dispatcher 1.7-0ubuntu3.4
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5395-1 CVE-2022-29799, CVE-2022-29800
Package Information:
launchpad.net/ubuntu/+source/networkd-dispatcher/2.1-2ubuntu0.22.04.1
launchpad.net/ubuntu/+source/networkd-dispatcher/2.1-2ubuntu0.21.10.1
launchpad.net/ubuntu/+source/networkd-dispatcher/2.1-2~ubuntu20.04.2 launchpad.net/ubuntu/+source/networkd-dispatcher/1.7-0ubuntu3.4