[USN-5488-1] OpenSSL vulnerability


========================================================================== Ubuntu Security Notice USN-5488-1 June 21, 2022
openssl, openssl1.0 vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 22.04 LTS – Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
OpenSSL could be made to crash or run programs when the c_rehash script is used.
Software Description: – openssl: Secure Socket Layer (SSL) cryptographic library and tools – openssl1.0: Secure Socket Layer (SSL) cryptographic library and tools
Details:
Chancen and Daniel Fiala discovered that OpenSSL incorrectly handled the c_rehash script. A local attacker could possibly use this issue to execute arbitrary commands when c_rehash is run.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 22.04 LTS: openssl 3.0.2-0ubuntu1.5
Ubuntu 21.10: openssl 1.1.1l-1ubuntu1.5
Ubuntu 20.04 LTS: openssl 1.1.1f-1ubuntu2.15
Ubuntu 18.04 LTS: openssl 1.1.1-1ubuntu2.1~18.04.19 openssl1.0 1.0.2n-1ubuntu5.10
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5488-1 CVE-2022-2068
Package Information: launchpad.net/ubuntu/+source/openssl/3.0.2-0ubuntu1.5 launchpad.net/ubuntu/+source/openssl/1.1.1l-1ubuntu1.5 launchpad.net/ubuntu/+source/openssl/1.1.1f-1ubuntu2.15 launchpad.net/ubuntu/+source/openssl/1.1.1-1ubuntu2.1~18.04.19 launchpad.net/ubuntu/+source/openssl1.0/1.0.2n-1ubuntu5.10