[USN-5492-1] Vim vulnerability


========================================================================== Ubuntu Security Notice USN-5492-1 June 23, 2022
vim vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 16.04 ESM
Summary:
Vim could be made to crash if it opened a specially crafted file.
Software Description: – vim: Vi IMproved – enhanced vi editor
Details:
It was discovered that Vim incorrectly handled memory when opening and searching the contents of certain files. If an attacker could trick a user into opening a specially crafted file, it could cause Vim to crash.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 16.04 ESM: vim 2:7.4.1689-3ubuntu1.5+esm7
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5492-1 CVE-2022-2042