[USN-5256-1] uriparser vulnerabilities


========================================================================== Ubuntu Security Notice USN-5256-1 July 13, 2022
uriparser vulnerabilities ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 18.04 LTS
Summary:
uriparser could be made to crash if it received specially crafted input.
Software Description: – uriparser: Strictly RFC 3986 compliant URI parsing library
Details:
It was discovered that uriparser incorrectly handled certain memory operations. An attacker could use this to cause a denial of service. (CVE-2021-46141, CVE-2021-46142)
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 18.04 LTS:   liburiparser-dev                0.8.4-1+deb9u2ubuntu0.1   liburiparser1                   0.8.4-1+deb9u2ubuntu0.1
In general, a standard system update will make all the necessary changes.
References:   ubuntu.com/security/notices/USN-5256-1   CVE-2021-46141, CVE-2021-46142
Package Information: launchpad.net/ubuntu/+source/uriparser/0.8.4-1+deb9u2ubuntu0.1