[USN-5508-1] Python LDAP vulnerability


========================================================================== Ubuntu Security Notice USN-5508-1 July 11, 2022
python-ldap vulnerability ==========================================================================
A security issue affects these releases of Ubuntu and its derivatives:
– Ubuntu 22.04 LTS – Ubuntu 21.10 – Ubuntu 20.04 LTS – Ubuntu 18.04 LTS
Summary:
Python LDAP could be made to denial of service if it received a specially crafted regular expression.
Software Description: – python-ldap: LDAP interface module for Python3
Details:
It was discovered that Python LDAP incorrectly handled certain regular expressions. An remote attacker could possibly use this issue to cause a denial of service.
Update instructions:
The problem can be corrected by updating your system to the following package versions:
Ubuntu 22.04 LTS: python3-ldap 3.2.0-4ubuntu7.1 python3-pyldap 3.2.0-4ubuntu7.1
Ubuntu 21.10: python3-ldap 3.2.0-4ubuntu5.1 python3-pyldap 3.2.0-4ubuntu5.1
Ubuntu 20.04 LTS: python3-ldap 3.2.0-4ubuntu2.1 python3-pyldap 3.2.0-4ubuntu2.1
Ubuntu 18.04 LTS: python-ldap 3.0.0-1ubuntu0.2 python-pyldap 3.0.0-1ubuntu0.2 python3-ldap 3.0.0-1ubuntu0.2 python3-pyldap 3.0.0-1ubuntu0.2
In general, a standard system update will make all the necessary changes.
References: ubuntu.com/security/notices/USN-5508-1 CVE-2021-46823
Package Information: launchpad.net/ubuntu/+source/python-ldap/3.2.0-4ubuntu7.1 launchpad.net/ubuntu/+source/python-ldap/3.2.0-4ubuntu5.1 launchpad.net/ubuntu/+source/python-ldap/3.2.0-4ubuntu2.1 launchpad.net/ubuntu/+source/python-ldap/3.0.0-1ubuntu0.2